Skip to main content
If you are using an earlier version please use sharelatex instead of overleaf in path names.
Mounting a NFS filesystem in an Overleaf container is technically possible, but it’s not recommended and can result in different types of performance errors.One common error that compiles see is:
In particular we advise against using NFS backed filesystems for ephemeral data, like the directories used for compilation data. We recommend using a local scratch disk, preferably a local SSD for the following directories.For docker-compose based setups, we suggest just overriding the bind-mount from NFS, which avoids changing paths in the application. Here’s an example of a docker-compose config excerpt with the use of a scratch disk that is mounted at /scratch:
docker-compose excerpt
There is no need to migrate any existing files from the NFS to their new home after the update. The LaTeX compiler can recreate all the files with a full compilation run again.For more details see: https://docs.overleaf.com/on-premises/support/troubleshooting#running-overleaf-with-an-nfs-filesystem
If you’re running Overleaf on Windows or macOS, the mongo service may fail to restart, with an error:
Example error
To avoid this error, the data needs to be stored in a volume rather than a bind mounted directory (see the mongo image documentation for more details: https://github.com/docker-library/docs/blob/master/mongo/content.md#where-to-store-data). To store data inside Docker volumes mounted inside the MongoDB and Redis containers, add the following to config/docker-compose.override.yml (create this file if it doesn’t exist yet):
config/docker-compose.override.yml
For more information see: https://docs.overleaf.com/on-premises/support/troubleshooting#running-overleaf-on-windows-or-macos-results-in-the-mongoservice-not-starting
Use the docker logs redis command to output a copy of the logs.If you see the line Fatal: Can't initialize Background Jobs, the full output will look something like this:
Redis log example
This may be related to the version of Docker currently in use. Updating to a version >= 20.10.10 should resolve this issue.For more information, see the Redis upstream issue: https://github.com/redis/redis/issues/12362Reference: https://docs.overleaf.com/on-premises/support/troubleshooting#upgrading-to-redis-6.2-results-in-a-restart-loop
The \write18 command is disabled by default in the Community Edition due to all compiles happening within the same sharelatex container; this is the safer default.If you wish to enable it for pdflatex, create a latexmkrc file in the root of your project with the following content:
latexmkrc
Then try recompiling.Reference: https://docs.overleaf.com/on-premises/support/troubleshooting#please-verify-that-you-have-enabled-system-calls.-for-pdflatex-this-is-pdflatex-shell-escape
Last modified on October 4, 2026